Issue
On May 25, 2023, the Endpoint Agent displayed the following error message.
"UserAgent.app" is damaged and can't be opened.
This only impacts the agent user interface menu on the device. The endpoint is still protected.
Environments
- Nebula
- OneView
- macOS endpoints
Cause
The previous UserAgent.app release included image resource name changes which caused an issue during the update cycle. When the UserAgent.app was copied to the correct location, it included resources that were not in the original Apple code signed application. This prevented the UserAgent.app from opening correctly, as the additional resources caused the signature validation to fail.
Resolution
An agent update to version 1.7.0.132 was automatically distributed to your endpoints. To manually update endpoints missing this version, follow the steps below.
- On the left navigation menu, go to Manage > Endpoints.
- Select the affected endpoints.
- In the top-right, click Actions > Check for Agent Updates.