Issue
Unable to install endpoint agent on Windows devices.
Environments
- OneView
- Windows devices
Symptoms
During installation, did you encounter one of the following:
- An error message
- Endpoint agent not showing on device
- Endpoint not displayed on the Endpoints page
Check for error
The installation attempt failed and a verbose log is needed to troubleshoot the issue. From the local device:
- Copy the following command to a text file:
msiexec /i "<fullpath1>\[setupfile].msi" /lv %userprofile%\desktop\MBInstallVerbose.log
- Replace <fullpath1> and [setupfile] with the path and name of the setup file.
- Copy and paste the command into an elevated Windows Command Prompt.
- A MBInstallVerbose.log is created on the desktop.
- Open the MBInstallVerbose.log with a text editor.
- Search for the error message:
Installation success or error status: 1603
Cause
Installation rollback may cause the installation to fail.
Resolution
Modify the Windows registry to disable rollback on the endpoint, then try installing again.
CAUTION - Modifying the registry can have serious consequences if done incorrectly. Ensure you have a backup of your registry or create a system restore point before making any changes. For more information, see How to back up and restore the registry in Windows.
- On the endpoint, press the Windows key + R on your keyboard.
- In the Run box, type regedit and press Ok.
- Navigate to HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Installer
- If the Installer key does not exist, create it.
- Right-click on the Windows key and select New > Key. A new key is created.
- Name the key Installer.
- If the DisableRollback entry does not exist within the Installer key, create it.
- Right-click on the Installer key and select New > DWORD (32-bit) Value.
- Name the entry DisableRollback.
- If the Installer key does not exist, create it.
- Disable installation rollback on the endpoint. For more information, see DisableRollback.
- Double-click on DisableRollback and update the value to 1.
- Click Ok.
- Setting the value back to 0 will enable rollback functionality.
- Close the registry editor.
- Run the Endpoint Agent installer again as an administrator.
If the issue persists, contact Support by opening a ticket and attach the verbose log.