Issue
Users are reporting the desktop client for Microsoft Outlook hanging and crashing on Windows devices.
Environments
- Windows 10
- Windows 11
- Nebula
Cause
A recent update to Microsoft Outlook is causing a conflict with our Exploit Protection DLLs.
Workaround
On April 25, 2025, we temporarily disabled the Block potentially malicious email attachments (Outlook desktop only) protection policy setting and removed Outlook.exe as an Exploit Protection protected application while we investigate a fix.
Your endpoints remain protected with the other protection layers running on them. These settings will be re-enabled once we identify a fix that balances protection and usability.