When your Endpoint Agent service is not running, you may encounter the error 14001 when starting the service:
- Windows could not start the Endpoint Agent service on Local Computer.
Error 14001: The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.
Symptoms
- Endpoint shows offline
- Endpoint Agent service is not running
Environments
- Windows endpoints
Cause
The MBCloudEA.exe.config may be corrupted. This can happen when the endpoint loses power while saving a setting to the file.
The Endpoint Agent stores and retrieves settings from MBCloudEA.exe.config located in C:\Program Files\Malwarebytes Endpoint Agent\.
Resolution
The endpoint agent automatically creates up to five backups of the configuration file on a regular schedule. Use the Configuration Recovery Tool located on the endpoint to restore MBCloudEA.exe.config from a backup.
- On the endpoint, open Command Prompt as an administrator.
- In the command window, type cd C:\Program Files\Malwarebytes Endpoint Agent
- In the command window, type ConfigurationRecoveryTool.exe MBCloudEA.exe
The tool attempts to restore MBCloudEA.exe from the latest backup. If unsuccessful, the tool continues the process with the remaining backups. The following error message displays:
No valid backup configuration was found, writing a new configuration file
Minimal configuration written, attempting to restart the service
Determining if service can be restarted
Account token located, restart the service
Service successfully started, verify the service is running properly
Configuration recovery operation complete - (0)
This means the tool was able to successfully recover the configuration.
If you're still encountering issues with the Endpoint Agent service, contact Support.