Issue
The following error is received during the installation of the endpoint agent:
- Endpoint Agent Setup Wizard ended prematurely.
Symptoms
Received the following error during the installation of the Endpoint Agent:
- Endpoint Agent Setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again. Click the Finish button to exit the Setup Wizard.
Environments
- Nebula
- OneView
- Windows
Cause
The error could be due to different environmental requirements. The MSI installation log will typically show the error received, providing a possible clue about the cause.
Resolution
- Use the following command in an elevated Windows Command Prompt to generate a verbose log file. This log file may contain helpful error messages to help troubleshoot the error.
msiexec /i "<fullpath1>\Setup.MBEndpointAgent.x64.msi" /lv %userprofile%\desktop\MBInstallVerbose.log
- Replace <fullpath1> with the path of the MSI file.
- A MBInstallVerbose.log is created on the desktop.
- Below is an example output where the MBInstallVerbose.log file shows an error at the end of the file.
=== Logging stopped: 5/4/2023 15:09:33 ===
MSI (c) (BC:F8) [15:09:33:060]: Product: Endpoint Agent -- Installation failed.
MSI (c) (BC:F8) [15:09:33:060]: Windows Installer installed the product. Product Name: Malwarebytes Endpoint Agent. Product Version: 1.2.0.986. Product Language: 1033. Manufacturer: Malwarebytes. Installation success or error status: 1603.
- Search the Support site for the error displayed.
- If no article is found, contact Support.